Windows 10, 8, 7 : Auto Backup Cpanel dengan Task Scheduler + Winscp

Melanjutkan tulisan sebelumnya tentang :
1. Linux : Auto Backup dari Cpanel ke Lokal dengan Ncftp + Crontab
2. Linux : Auto Backup dengan Crontab + Ncftpput
Sekarang akan diimplementasikan pada Windows 10 menggunakan Task Scheduler + aplikasi FTP klien bernama Winscp.

Kebutuhan dasar :
Winscp sebagai aplikasi FTP klien, unduh pada situs resminya dan instal.

https://winscp.net/eng/download.php

Langkah-langkah membuat trigger harian untuk menjalankan unduh berkas sebagai backup :

  • Buka Control Panel:
    • Windows 10 and Windows 8.1: Klik kanan tombol Windows Start dan pilih Control Panel.
    • Windows 7: Windows Start Menu > Control Panel.
  • Control Panel, lanjutkan dengan System and Security > Administrative Tools > Schedule Tasks.
  • Pada menu Task Scheduler pilih Action > Create Basic Task.

task-scheduler1

  • Isikan nama dan deskripsi lalu Next.

task-scheduler2

  • Pilih opsi untuk menjalankan harian (Daily).

task-scheduler3

  • Atur waktu untuk memberlakukan skrip.

task-scheduler4

  • Pilih opsi Start a program, karena Winscp adalah aplikasi.

task-scheduler5

  • Isikan Program / script dengan lokasi aplikasi Winscp, dan beri argumen sebagai berikut :
/log=c:\backup\winscp.log /command "open ftp://myusername:mypassword@myserver.com/" "get /* c:\backup\" "exit"
  • Syntax get berarti mengunduh berkas. Pastikan untuk menyesuaikan username, password, alamat server dan folder remote dan lokalnya.

task-scheduler6

  • Centang Open the Properties… untuk pengaturan lebih lanjut, lalu Finish

task-scheduler7

  • Pilih opsi Security “Run whether user is logged on or not“, untuk membuat perintah dijalankan sekalipun komputer dalam keadaan tidak logged. Untuk setiap perubahan isikan password komputer anda.

task-scheduler8

Oke selesai, silahkan mencoba 🙂

Linux : Auto Backup dari Cpanel ke Lokal dengan Ncftp + Crontab

Tulisan ini sebenarnya melengkapi tulisan mengenai “Auto Backup dengan Crontab + Ncftpput“. Perbedaannya adalah memposisikan pelaksanaan skrip pada komputer lokal yang akan mengurangi beban server utama. Sedangkan pada tulisan sebelumnya posisi skrip berada di server utama sehingga bisa jadi membutuhkan waktu-waktu tertentu saat traffic sedang rendah agar skrip tidak membebani server. Selain itu ada contoh mengenai pembuatan akun File Transfer Protocol (FTP) di Cpanel. Walaupun pada dasarnya semua FTP server dapat diakses oleh aplikasi FTP klien seperti Ncftp yang akan kita gunakan dalam skrip.

Kebutuhan dasar :
1. Debian atau turunannya,
2. Crontab & Ncftp.
3. Akun FTP pada Cpanel, bila belum tersedia ikuti langkah berikut :

Dari home, klik menu FTP Accounts
screenshot-from-2016-12-14-18-51-26

screenshot-from-2016-12-14-20-38-31

Setelah memiliki akun FTP selanjutnya langkah pertama, membuat skrip bash simpan dengan nama ftp.backup.sh :

#!/bin/sh
USERNAME="tes@myserver.com"
PASSWORD="mypassword"
SERVER="ftp.myserver.com"
PORT=21

#folder lokal
BACKUPDIR="/home/dino/backup"

#folder pada server utama
FILE="/"

#login to remote server
ncftpget -R -v -u $USERNAME -p $PASSWORD -P $PORT $SERVER $BACKUPDIR $FILE

Uji skrip dengan menjalankan perintah berikut, lalu cek pada folder backup apakah file telah berhasil diunduh :

bash ftp.backup.sh

Sama seperti artikel sebelumnya lakukan edit Crontab untuk membuat skrip dijalankan secara otomatis.

crontab -e

Tambahkan baris baru dengan struktur :

 +---------------- minute (0 - 59)
 |  +------------- hour (0 - 23)
 |  |  +---------- day of month (1 - 31)
 |  |  |  +------- month (1 - 12)
 |  |  |  |  +---- day of week (0 - 6) (Sunday=0 or 7)
 |  |  |  |  |
 *  *  *  *  *  command to be executed

Contoh kasus apabila backup dilakukan setiap pukul 23:00 waktu server :

0 23 * * * /home/user/skrip.upload.sh

Sampai disini langkahnya selesai, selamat menambah jam istirahat dan biarkan server melakukan tugasnya. Sesekali cek folder backup untuk memastikan berkas dapat terunduh dengan baik 😉

Linux : Auto Backup dengan Crontab + Ncftpput

Bagi para pemilik website yang selalu dinamis pastinya akan semakin intens untuk melakukan backup. Sehingga seringkali harus menyempatkan diri pada waktu-waktu tertentu tidak perduli hari libur. Karena bisa jadi saat kita lengah, kita kehilangan data. Bisa dikarenakan kelalaian, serangan hacker ataupun karena kerusakan hardware.

Ada tiga jenis tipe backup, yaitu : Cold backup sites, Warm backup sites dan Hot backup sites. Namun kita tidak akan membahasnya satu persatu karena bisa dicari di google pengertiannya, lalu yang selanjutnya ini hanya sebagai trik agar rekan-rekan pengelola website tidak overtime bekerjanya. Supaya waktu yg tersisa bisa buat keluarga, dan backup berjalan otomatis 😛  Trik berikut bisa jadi digolongkan ke Warm backup karena proses restore-nya tetap akan dihantarkan secara manual.

Prinsipnya proses backup berupa menjalankan skrip yang isinya perintah untuk aplikasi File Transfer Protocol (FTP) men-copy folder ke Server Backup pada waktu tertentu dengan bantuan Crontab. Crontab adalah aplikasi yang dapat menjalankan perintah secara otomatis pada waktu yang telah diatur. FTP yang digunakan bisa apa saja tapi sebagai contoh kita akan menggunakan Ncftp.

Kebutuhan dasar :
1. Server backup dengan fitur FTP, bisa berupa Network Attached Storage (NAS) apabila on-site atau melalui jaringan Virtual Private Network (VPN),
2. Server backup telah terkonfigurasi dengan akun FTP,
3. Debian atau turunannya,
4. Fungsi cronjob dan ncftpput

sudo apt-get update
sudo apt-get install ncftp

Penerapan :
Langkah pertama, membuat skrip bash

nano skrip.upload.sh

Isikan perintah ncftp pada file tersebut dan simpan file.

#!/bin/sh
USERNAME="myftpusername"
PASSWORD="myftppassword"
SERVER="ftp.myserver.com"
PORT=1234

# direktori lokal yang akan dibackup
FILE="/public_html"

# direktori pada remote server untuk upload backup
BACKUPDIR="/home/admin/web/backup"

# login ke remote server dan upload
ncftpput -R -v -u $USERNAME -p $PASSWORD -P $PORT $SERVER /~ $FILE

Selanjutnya edit Crontab

crontab -e

Tambahkan baris baru dengan struktur :

 +---------------- minute (0 - 59)
 |  +------------- hour (0 - 23)
 |  |  +---------- day of month (1 - 31)
 |  |  |  +------- month (1 - 12)
 |  |  |  |  +---- day of week (0 - 6) (Sunday=0 or 7)
 |  |  |  |  |
 *  *  *  *  *  command to be executed

Contoh kasus apabila backup dilakukan setiap pukul 23:00 waktu server :

0 23 * * * /home/user/skrip.upload.sh

Sampai disini langkahnya sudah cukup untuk meringankan kerja pengelola website, tinggal di-monitor saja sekali-kali diintip apa benar file-nya berhasil di-backup. Selamat mencoba 😉

Mikrotik : Kumpulan Skrip Firewall

Musim hacker menyerang situs pemerintahan biasanya saat momen Nasional ataupun Hari Besar Nasional dan membuat pusing para admin yang harus mengamankan asetnya berupa Server dan Data. Untuk membuat lengah para pengelola Server, mereka kadang membuat decoy (umpan) / pengalihan sehingga tanpa disadari hacker sudah menyusupi sistem. Pengalihan bisa berupa serangan DDoS (Distributed Denial of Service) yang membanjiri traffic dari koneksi Server. Karena dibanjiri, server akan kewalahan dan kadang-kadang admin bisa bertindak ceroboh.

Kali ini saya akan membagikan beberapa konfigurasi firewall untuk mikrotik. Indikasi awalnya terlihat traffic yang sangat besar pada Tx / Transmit (Bandwith Upload), jika monitor menunjukkan batas yang lebih dari bandwith aslinya dan sifatnya intense, ini berarti jaringan anda sedang dibanjiri (UDP Flooding). Pastikan sebelum menjalankan skrip ganti x.x.x.x dengan IP publik atau IP WAN anda.

/ip firewall filter

;;; Drop UDP FLOODING
add action=drop chain=input comment="Drop UDP Flooding" disabled=no \
    dst-address=x.x.x.x dst-port=53 protocol=udp src-address-list=\
    udp_blacklist
add action=add-src-to-address-list address-list=udp_blacklist \
    address-list-timeout=1w3d chain=input connection-state=new disabled=no \
    dst-address=x.x.x.x dst-port=53 protocol=udp src-address-list=\
    udp_stage3
add action=add-src-to-address-list address-list=udp_stage3 \
    address-list-timeout=1m chain=input connection-state=new disabled=no \
    dst-address=x.x.x.x dst-port=53 protocol=udp src-address-list=\
    udp_stage2
add action=add-src-to-address-list address-list=udp_stage2 \
    address-list-timeout=1m chain=input connection-state=new disabled=no \
    dst-address=x.x.x.x dst-port=53 protocol=udp src-address-list=\
    udp_stage1
add action=add-src-to-address-list address-list=udp_stage1 \
    address-list-timeout=1m chain=input connection-state=new disabled=no \
    dst-address=x.x.x.x dst-port=53 protocol=udp
	
;;; Drop SIP FLOODING
add action=drop chain=input comment="Drop SIP Flooding" disabled=no \
    dst-address=x.x.x.x dst-port=5060 protocol=udp src-address-list=\
    sip_blacklist
add action=add-src-to-address-list address-list=sip_blacklist \
    address-list-timeout=0s chain=input connection-state=new disabled=no \
    dst-address=x.x.x.x dst-port=5060 protocol=udp

Dengan penggunaan drop pada mikrotik tidak akan membuat CPU menjadi panas. Namun penggunaan address-list bisa membuat memori penuh jadi perhatikan timeout-nya dan hapus penggunaan address-list jika mikrotik anda tidak mumpuni. Penggunaan address-list adalah agar anda bisa mengevaluasi dan menganalisis serangan. Berikut ini tambahan untuk port lainnya yang terindikasi dan umumnya digunakan Virus, Worm dan sebagainya.

;;; Drop Virus Worm dan para dedengkotnya
add action=accept chain=forward comment="allow established connections" \
    connection-state=established disabled=no
add action=accept chain=forward comment="allow related connections" \
    connection-state=related disabled=no
add action=drop chain=forward comment="drop invalid connections" \
    connection-state=invalid disabled=no
add action=jump chain=forward comment="jump to the virus chain" disabled=no \
    jump-target=virus
	
add action=drop chain=virus comment="Drop Blaster Worm" disabled=no dst-port=\
    135-139 protocol=tcp
add action=drop chain=virus comment="Drop Messenger Worm" disabled=no \
    dst-port=135-139 protocol=udp
add action=drop chain=virus comment="Drop Blaster Worm" disabled=no dst-port=\
    445 protocol=tcp
add action=drop chain=virus comment="Drop Blaster Worm" disabled=no dst-port=\
    445 protocol=udp
add action=drop chain=virus comment=________ disabled=no dst-port=593 \
    protocol=tcp
add action=drop chain=virus comment=________ disabled=no dst-port=1024-1030 \
    protocol=tcp
add action=drop chain=virus comment="Drop MyDoom" disabled=no dst-port=1080 \
    protocol=tcp
add action=drop chain=virus comment=________ disabled=no dst-port=1214 \
    protocol=tcp
add action=drop chain=virus comment="ndm requester" disabled=no dst-port=1363 \
    protocol=tcp
add action=drop chain=virus comment="ndm server" disabled=no dst-port=1364 \
    protocol=tcp
add action=drop chain=virus comment="screen cast" disabled=no dst-port=1368 \
    protocol=tcp
add action=drop chain=virus comment=hromgrafx disabled=no dst-port=1373 \
    protocol=tcp
add action=drop chain=virus comment=cichlid disabled=no dst-port=1377 \
    protocol=tcp
add action=drop chain=virus comment=Worm disabled=no dst-port=1433-1434 \
    protocol=tcp
add action=drop chain=virus comment="Bagle Virus" disabled=no dst-port=2745 \
    protocol=tcp
add action=drop chain=virus comment="Drop Dumaru.Y" disabled=no dst-port=2283 \
    protocol=tcp
add action=drop chain=virus comment="Drop Beagle" disabled=no dst-port=2535 \
    protocol=tcp
add action=drop chain=virus comment="Drop Beagle.C-K" disabled=no dst-port=\
    2745 protocol=tcp
add action=drop chain=virus comment="Drop MyDoom" disabled=no dst-port=\
    3127-3128 protocol=tcp
add action=drop chain=virus comment="Drop Backdoor OptixPro" disabled=no \
    dst-port=3410 protocol=tcp
add action=drop chain=virus comment="Drop Sasser" disabled=no dst-port=5554 \
    protocol=tcp
add action=drop chain=virus comment="Drop Beagle.B" disabled=no dst-port=8866 \
    protocol=tcp
add action=drop chain=virus comment="Drop Dabber.A-B" disabled=no dst-port=\
    9898 protocol=tcp
add action=drop chain=virus comment="Drop Dumaru.Y" disabled=no dst-port=\
    10000 protocol=tcp
add action=drop chain=virus comment="Drop MyDoom.B" disabled=no dst-port=\
    10080 protocol=tcp
add action=drop chain=virus comment="Drop NetBus" disabled=no dst-port=12345 \
    protocol=tcp
add action=drop chain=virus comment="Drop Kuang2" disabled=no dst-port=17300 \
    protocol=tcp
add action=drop chain=virus comment="Drop SubSeven" disabled=no dst-port=\
    27374 protocol=tcp
add action=drop chain=virus comment="Drop PhatBot, Agobot, Gaobot" disabled=\
    no dst-port=65506 protocol=tcp

Tambahan untuk menangkal yang coba-coba login SSH.

;;; Drop SSH Brute Force
add action=drop chain=input comment="Drop SSH Brute Forcers" disabled=no \
    dst-port=22 protocol=tcp src-address-list=ssh_blacklist
add action=add-src-to-address-list address-list=ssh_blacklist \
    address-list-timeout=1w3d chain=input connection-state=new disabled=no \
    dst-port=22 protocol=tcp src-address-list=ssh_stage3
add action=add-src-to-address-list address-list=ssh_stage3 \
    address-list-timeout=1m chain=input connection-state=new disabled=no \
    dst-port=22 protocol=tcp src-address-list=ssh_stage2
add action=add-src-to-address-list address-list=ssh_stage2 \
    address-list-timeout=1m chain=input connection-state=new disabled=no \
    dst-port=22 protocol=tcp src-address-list=ssh_stage1
add action=add-src-to-address-list address-list=ssh_stage1 \
    address-list-timeout=1m chain=input connection-state=new disabled=no \
    dst-port=22 protocol=tcp

Solved : Winbox “Could not connect port 20651. Timeout!”

Suatu ketika saya tidak bisa remote mikrotik menggunakan aplikasi winbox. Sudah mencoba memperbarui aplikasi, uninstall dan install kembali masih juga tidak bisa masuk dan muncul pesan “Could not connect port 20651. Timeout!”. Hasil pencarian di google menyebutkan bahwa kemungkinan saya memiliki Virtual Network Adapter / Tap-Win32 Adapter yang biasanya digunakan untuk aplikasi proxy. Namun setelah saya cek daftar network adapter di komputer saya, tidak ada Tap-Win32 adanya hanya VirtualBox Host-Only Network yang merupakan Virtual Adapter dari aplikasi VirtualBox yang saya gunakan untuk menjalankan Genymotion (Emulator Android).

virtual-adapter

Tapi karena saya pikir sama-sama mengandung istilah Virtual 😉 tidak ada salahnya mencoba trik yang diberlakukan di Tap-Win32. Alih-alih disarankan untuk menghapus, saya mimilih hanya men-disable saja karena saya masih membutuhkan dan jika diperlukan tinggal enable kembali, 😯 dan ternyata hasilnya winbox bisa konek lagi.

 

Genymotion : Emulator Android

Artikel kali ini saya akan menunjukkan bagaimana melakukan instalasi Genymotion paling populer, mudah & cepat.

Genymotion adalah emulator Android berbasiskan VirtualBox, sekalipun demikian tidak mengharuskan Anda untuk menginstal VirtualBox (akan tetapi akan lebih baik jika Anda telah menginstalnya karena sudah satu paket dengan installer yang tersedia). Selain itu, Genymotion dapat meniru perangkat tertentu dan memungkinkan Anda untuk menginstal aplikasi / menjalankan / melakukan tes. Kelebihannya lagi VirtualBox adalah cross-platform yang kompatibel dengan berbagai Sistem Operasi, Genymotion akan bekerja pada Windows, Mac dan juga Linux.

Virtual images yang tersedia dan dapat diunduh: Android 4.1.1, 4.2.2 and 4.3, 4.4.4, 5.0.0, 5.1.0, 6.0.0 (with x86 support): Galaxy Nexus, Nexus 10, Nexus 4, Nexus 5, Nexus 5X, Nexus 6, Nexus 6P, Nexus 7, Nexus 7 2013, Nexus 9, Nexus One, HTC Evo, HTC One, HTC One X, LG Optimus L3 II, Moto Droid Razer, Moto X, Moto Xoom, Galaxy Note, Galaxy S2, Galaxy S3, Galaxy S4, Xperia Z, Xperia Y, WXGA 10.1” Tablet dan WSVGA 7.0” Tablet;
1. Networking: Ethernet (mengemulasi koneksi Wifi).
2. GPS (dapat diset koordinat) dan baterai (dapat dikonfigurasi level) .
3. Display: OpenGL hardware acceleration, multiscreen, full screen.
4. Genymotion shell memperbolehkan interaksi dengan VM menggunakan command-line.
5. Tersedia ADB.
6. Plugin untuk Eclipse and Android Studio.

Kebutuhan sistem :
1. Kartu grafis dengan OpenGL 2.0 dan up-to-date driver
2. VT-x / AMD-V CPU, serta tersedia pengaturan BIOS
3. Minimal 2GB RAM memory
4. Minimal 100MB free space pada Hard Drive untuk instalasi Genymotion
Minimal 2GB free space untuk deploy setiap perangkat virtual Genymotion. Kemungkinan akan membutuhkan lebih dari 8GB bergantung pada pilihan perangkat virtual dan aplikasi yang diinstal didalamnya.
5. Koneksi Internet (untuk instalasi dan update)
6. Resolusi minimal 1024 x 768 pixels

Download dan Install  Oracle Virtual Box:
Windows
Cara termudah adalah mengunduh genymotion yang telah sepaket dengan VirtualBox
Mac OS X
Menuju ke halaman unduh VirtualBox dan dapatkan berkas Mac OS X .dmg. Buka .dmg dan jalankan installer, ikuti langkah instalasi selanjutnya. Setelah selesai, reboot.
Linux
Cek repo: hampir semua GNU/Linux memiliki paket installer untuk VirtualBox. Jika tidak atau butuh instalasi versi yang spesifik, unduh VirtualBox tersendiri.

Instalasi Genymotion

Untuk memulai, anda harus menuju ke situs Genymotion dan melakukan pendaftaran akun baru. Anda akan dapat mengunduh instaler setelah selesai melakukan pendaftaran.
1. Menuju ke laman pendaftaran Genymotion
2. Pada form pendaftaran, isikan dengan informasi personal.
3. Klik tombol “SIGN UP”
4. Anda akan menerima validasi melalui E-mail. Klik pada tautan validasi untuk menyelesaikan validasi.
5. E-mail berikutnya registrasi anda telah komplit.
6. Selanjutnya jalankan Genymotion, akan muncul pop-up pertanyaan, tambahkan perangkat virtual pilih YES.
"Add a virtual device" popup

7. Lakukan login untuk mengakses pilihan perangkat.
"Credentials" window

8. Pilih salah satu perangkat lalu klik Next.
"Available virtual devices" list

9. Klik “Start” untuk menjalankan perangkat yang telah dipilih sebelumnya.
Virtual device main window

Selamat mencoba 🙂

Amatir Fotografi untuk Reportase PB

Memberikan laporan baik pada saat bencana berlangsung maupun setelahnya dan pada saat kegiatan PB berakhir merupakan salah satu tugas krusial yang tidak bisa ditinggalkan. Dengan kecanggihan teknologi tidak ada lagi bentuk laporan yang sederhana dan hanya berupa tulisan. Laporan awal yang singkatpun sekarang disertai dengan gambar dan dikirim langsung melalui aplikasi chatting. Kali ini penulis akan berbagi mengenai tips reportase fotografi yang memenuhi syarat minimal untuk dapat digunakan sebagai bahan laporan.

(1) Gunakan Moda Auto, untuk amatir akan lebih mudah menggunakan moda ini kamera akan secara otomatis menentukan konfigurasi sesuai dengan pembacaan sensor terhadap kondisi lingkungan.
(2) Moda landscape untuk menggambarkan situasi yang lebih lebar dan bukan untuk fokus terhadap satu obyek. Moda ini memiliki keunggulan untuk reportase karena pengguna kamera tidak perlu menentukan fokus sehingga momen dapat diambil dengan cepat. Hasilnya tidak ada perbedaan kedalaman (depth of field) antara obyek satu dengan yang lain. Dalam bahasa amatir semua obyek terlihat fokus.
(3) Mengambil gambar lebih dari satu untuk setiap momen. Jangan sia-siakan momen, karena hanya ada sekali dalam setiap tindakan.
(4) Meminta perbaikan pose jika dapat dilakukan.
(5) Atur jarak dengan obyek, beri ruang untuk cropping (pemotongan area pada gambar) agar foto dapat menyesuaikan dengan format susunan gambar pada pelaporan.
(6) Jika ada kesempatan senggang segera hapus foto gagal atau foto yang tidak memiliki nilai dalam reportase karena sisa ruang penyimpanan akan dapat digunakan untuk momen lainnya dengan sesegera mungkin.
(7) Yang terpenting pelajari kamera yang digunakan, fitur dan kecanggihannya tidak akan muncul begitu saja apabila berada di konfigurasi yang salah.

Beberapa contoh foto yang diambil pada kegiatan PB Erupsi Gunung Bromo 2010 dapat dilihat pada link  >> klik disini <<

Fotografer reportase diharapkan dapat menghasilkan foto yang bercerita tanpa harus ditulis keterangannya secara mendetil. Di situasi PB yang hanya memberikan peluang kecil untuk momen dapat terulang kembali setidaknya tips diatas dapat menjadi panduan bagi rekan yang berada di arena PB, baik sebagai TRC (Tim Reaksi Cepat), Tim DALA (Damage and Lossess Assesment) ataupun fungsi dokumentasi.

Sistem Komando Tanggap Darurat PB

Apa yang akan terjadi pada saat bencana? Pada situasi darurat sering terjadi kesimpangsiuran informasi yang akan mempersulit upaya penanggulangan bencana (PB). Pelaksanaan PB terkesan lambat, kurang merata dan sulit terpantau, mungkin lebih cocok bila dikatakan penanganan yang sporadis. Kurangnya koordinasi antar instansi terkait dalam pelaksanaan PB sehingga terjadi tumpang tindih atau bahkan ada daerah-daerah yang tidak tertangani. Selain itu munculnya posko-posko tanggap darurat yang tidak resmi dan bahkan banyak pula posko-posko yang tidak ada aktivitasnya tapi bendera lembaganya terpancang megah. Oleh karena itu perlu adanya institusi yang menjadi pusat komando tanggap darurat PB.

Tanggap darurat adalah serangkaian kegiatan yang dilakukan dengan segera pada saat kejadian bencana untuk menangani dampak buruk yang ditimbulkan, yang meliputi kegiatan penyelamatan dan evakuasi korban, harta benda, pemenuhan kebutuhan dasar, perlindungan, pengurusan pengungsi, penyelamatan, serta pemulihan prasarana dan sarana. Tahapan keadaan darurat bencana meliputi Siaga Darurat, Tanggap Darurat dan Transisi ke Pemulihan.

Sistem Komando Tanggap Darurat Bencana adalah suatu standar penanganan darurat bencana yang mengintegrasikan pengerahan fasilitas, peralatan, personil, prosedur dan komunikasi dlm suatu struktur organisasi.

Komando tanggap darurat bencana adalah organisasi penanganan tanggap darurat bencana yang dipimpin oleh seorang Komandan dan dibantu oleh staf komando dan staf umum, memiliki struktur organisasi standar yang menganut satu komando dengan mata rantai dan garis komando yang jelas.

Staf Komando adalah pembantu Komandan Tanggap Darurat Bencana (KTDB) dalam menjalankan tugas kesekretariatan, hubungan masyarakat, perwakilan instansi/lembaga serta keselamatan dan keamanan.

Staf Umum adalah pembantu KTDB dalam menjalankan fungsi utama komando untuk bidang operasi, bidang perencanaan, bidang logistik dan bidang peralatan serta bidang administrasi keuangan untuk penanganan tanggap darurat.

Dalam masa tanggap darurat ini dilakukan kegiatan-kegiatan sebagai berikut (1) Pengkajian secara cepat dan tepat terhadap lokasi, kerusakan dan sumber daya, (2) Penentuan status keadaan darurat bencana, (3) Penyelamatan dan evakuasi masyarakat yang terkena bencana, (4) Pemenuhan kebutuhan dasar, (5) Perlindungan terhadap kelompok rentan, dan (6) Pemulihan dengan segera prasarana dan sarana vital.

Hal-hal yang terkait dengan tanggap darurat meliputi kemudahan akses dalam pengerahan SDM, peralatan dan logistik; kemudahan akses berupa komando dan sistem komando; pos komando tanggap darurat; pos komando lapangan tanggap darurat; dan penyusunan rencana operasi tanggap darurat.

Dengan adanya pemahaman yang baik terhadap Sistem Komando Tanggap Darurat PB diharapkan setiap personil BPBD mengerti tugas dan fungsinya masing-masing untuk berbaur dengan sistem secara otomatis dikala tanggap darurat diberlakukan. Dan tidak kalah penting memberikan masukan untuk kebaikan dan perbaikan PB sehingga di masa mendatang tidak lagi terjadi PB dengan cara sporadis. (DA)

Lebih lanjut tentang Sistem Komando Tanggap Darurat PB dapat dipelajari di Perka BNPB Nomor 10 Tahun 2008, dapat diunduh pada link berikut ini >> klik disini <<